NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Apache Wicket vulnerable to CSRF attacksGHSA-xc66-mg8r-q6r5

HIGH

GHSA-xc66-mg8r-q6r5 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in org.apache.wicket:wicket-core. A fix is available for org.apache.wicket:wicket-core — see the affected versions and patch details below.

Also known asCVE-2016-6806
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.88%1.32%0.2%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.wicket:wicket-core☕org.apache.wicket:wicket-core☕org.apache.wicket:wicket-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Wicket 6.x before 6.25.0, 7.x before 7.5.0, and 8.0.0-M1 provide a CSRF prevention measure that fails to discover some cross origin requests. The mitigation is to not only check the Origin HTTP header, but also take the Referer HTTP header into account when no Origin was provided. Furthermore, not all Wicket server side targets were subjected to the CSRF check. This was also fixed.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.wicket:wicket-core≥ 6.20.0&&< 6.25.06.25.0org.apache.wicket:wicket-core:6.25.0
☕Mavenorg.apache.wicket:wicket-core≥ 7.0.0&&< 7.5.07.5.0org.apache.wicket:wicket-core:7.5.0
☕Mavenorg.apache.wicket:wicket-core≥ 8.0.0-M1&&< 8.0.0-M28.0.0-M2org.apache.wicket:wicket-core:8.0.0-M2

Affected Products

1 product · 11 configurations
Application
wicketapache
11 versions
6.20.06.21.06.22.06.23.06.24.07.0.07.1.07.2.07.3.07.4.08.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.wicket:wicket-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.wicket:wicket-core to 6.25.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-xc66-mg8r-q6r5 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Apache Wicket 6.x before 6.25.0, 7.x before 7.5.0, and 8.0.0-M1 provide a CSRF prevention measure that fails to discover some cross origin requests. The mitigation is to not only check the Origin HTTP header, but also take the Referer HTTP header into account when no Origin was provided. Furthermore, not all Wicket server side targets were subjected to the CSRF check. This was also fixed.
O3 Security · Impact-Aware SCA

Is GHSA-xc66-mg8r-q6r5 in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Wicket vulnerable to CSRF attacks (High 8.8)