CVE-2016-6806 — wicket-core
HIGHCVE-2016-6806 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in org.apache.wicket:wicket-core. A fix is available for org.apache.wicket:wicket-core — see the affected versions and patch details below.
Apache Wicket vulnerable to CSRF attacks
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.wicket:wicket-core☕org.apache.wicket:wicket-core☕org.apache.wicket:wicket-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Wicket 6.x before 6.25.0, 7.x before 7.5.0, and 8.0.0-M1 provide a CSRF prevention measure that fails to discover some cross origin requests. The mitigation is to not only check the Origin HTTP header, but also take the Referer HTTP header into account when no Origin was provided. Furthermore, not all Wicket server side targets were subjected to the CSRF check. This was also fixed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.wicket:wicket-core | ≥ 6.20.0&&< 6.25.0 | 6.25.0org.apache.wicket:wicket-core:6.25.0 |
| ☕Maven | org.apache.wicket:wicket-core | ≥ 7.0.0&&< 7.5.0 | 7.5.0org.apache.wicket:wicket-core:7.5.0 |
| ☕Maven | org.apache.wicket:wicket-core | ≥ 8.0.0-M1&&< 8.0.0-M2 | 8.0.0-M2org.apache.wicket:wicket-core:8.0.0-M2 |
Affected Products
wicketapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.wicket:wicket-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.wicket:wicket-core to 6.25.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6806 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2016-6806 in your dependencies?
Find it across Maven, including transitive dependencies.