CVE-2014-0043 — wicket-core
MEDIUMCVE-2014-0043 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in org.apache.wicket:wicket-core. A fix is available for org.apache.wicket:wicket-core — see the affected versions and patch details below.
Apache Wicket allows attackers to check for third-party libraries
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.wicket:wicket-core☕org.apache.wicket:wicket-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Wicket 1.5.10 or 6.13.0, by issuing requests to special urls handled by Wicket, it is possible to check for the existence of particular classes in the classpath and thus check whether a third party library with a known security vulnerability is in use.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.wicket:wicket-core | ≥ 1.5-RC1&&< 1.5.11 | 1.5.11org.apache.wicket:wicket-core:1.5.11 |
| ☕Maven | org.apache.wicket:wicket-core | ≥ 6.0.0-beta1&&< 6.14.0 | 6.14.0org.apache.wicket:wicket-core:6.14.0 |
Affected Products
wicketapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.wicket:wicket-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.wicket:wicket-core to 1.5.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0043 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2014-0043 in your dependencies?
Find it across Maven, including transitive dependencies.