CVE-2020-11976 — wicket-core
HIGHCVE-2020-11976 is a high-severity (CVSS 7.5) CWE-552 vulnerability in org.apache.wicket:wicket-core. A fix is available for org.apache.wicket:wicket-core — see the affected versions and patch details below.
Exposure of Sensitive Information to an Unauthorized Actor in Apache Wicket
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.wicket:wicket-core☕org.apache.wicket:wicket-core☕org.apache.wicket:wicket-core☕org.apache.wicket:wicket-core☕org.apache.wicket:wicket-core☕org.apache.wicket:wicket-core☕org.apache.wicket:wicket-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
By crafting a special URL it is possible to make Wicket deliver unprocessed HTML templates. This would allow an attacker to see possibly sensitive information inside a HTML template that is usually removed during rendering. Affected are Apache Wicket versions 7.16.0, 8.8.0 and 9.0.0-M5
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.wicket:wicket-core | all versions | 7.17.0org.apache.wicket:wicket-core:7.17.0 |
| ☕Maven | org.apache.wicket:wicket-core | ≥ 8.0.0&&< 8.9.0 | 8.9.0org.apache.wicket:wicket-core:8.9.0 |
| ☕Maven | org.apache.wicket:wicket-core | ≥ 9.0.0-M1&&< 9.0.0 | 9.0.0org.apache.wicket:wicket-core:9.0.0 |
| ☕Maven | org.apache.wicket:wicket-core | ≥ 9.0.0-M2&&< 9.0.0 | 9.0.0org.apache.wicket:wicket-core:9.0.0 |
| ☕Maven | org.apache.wicket:wicket-core | ≥ 9.0.0-M3&&< 9.0.0 | 9.0.0org.apache.wicket:wicket-core:9.0.0 |
| ☕Maven | org.apache.wicket:wicket-core | ≥ 9.0.0-M4&&< 9.0.0 | 9.0.0org.apache.wicket:wicket-core:9.0.0 |
Affected Products
fortressapachewicketapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.wicket:wicket-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.wicket:wicket-core to 7.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-11976 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-11976 in your dependencies?
Find it across Maven, including transitive dependencies.