NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

OpenSearch Security plugin: DLS not applied on documents linked by has_child or has_parent relationGHSA-x83w-23jp-g6pw

MEDIUM

GHSA-x83w-23jp-g6pw is a medium-severity (CVSS 5.3) vulnerability in org.opensearch.plugin:opensearch-security. A fix is available for org.opensearch.plugin:opensearch-security — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of May 7, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
☕org.opensearch.plugin:opensearch-security☕org.opensearch.plugin:opensearch-security

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Description

A flaw was identified in the OpenSearch Security plugin's document-level security (DLS) implementation. DLS restrictions were not correctly applied to search queries that use has_parent or has_child join relations. This could allow an authenticated user to access document contents that should have been restricted by DLS rules.

Impact

An authenticated user with access to an index containing parent/child join relations could bypass DLS restrictions on documents linked by those relations, potentially accessing restricted document contents. This only affects clusters that use both DLS and the join field type on the same index.

Patches

This issue is fixed in OpenSearch 2.19.4 and 3.2.0.

Workarounds

Avoid using the join field type on indices that are subject to DLS rules.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.opensearch.plugin:opensearch-security≥ 1.0.0&&< 2.19.4.02.19.4.0org.opensearch.plugin:opensearch-security:2.19.4.0
☕Mavenorg.opensearch.plugin:opensearch-security≥ 3.0.0&&< 3.2.0.03.2.0.0org.opensearch.plugin:opensearch-security:3.2.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opensearch.plugin:opensearch-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.opensearch.plugin:opensearch-security to 2.19.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x83w-23jp-g6pw is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Description A flaw was identified in the OpenSearch Security plugin's document-level security (DLS) implementation. DLS restrictions were not correctly applied to search queries that use has_parent or has_child join relations. This could allow an authenticated user to access document contents that should have been restricted by DLS rules. ### Impact An authenticated user with access to an index containing parent/child join relations could bypass DLS restrictions on documents linked by those relations, potentially accessing restricted document contents. This only affects clusters that us
O3 Security · Impact-Aware SCA

Is GHSA-x83w-23jp-g6pw in your dependencies?

Find it across Maven, including transitive dependencies.

OpenSearch Security plugin: DLS not applied on…