OpenSearch has a bypass of REST Layer Authorization Using Malformed PathsGHSA-83x9-vc3c-hghc
LOWGHSA-83x9-vc3c-hghc is a low-severity (CVSS 3.7) vulnerability in org.opensearch.plugin:opensearch-security. A fix is available for org.opensearch.plugin:opensearch-security — see the affected versions and patch details below.
Real-World Exposure
org.opensearch.plugin:opensearch-securityReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Description
A flaw was identified in the OpenSearch REST layer that could allow authorization checks to be bypassed when processing certain malformed HTTP requests. This could permit unauthorized access to restricted API endpoints in environments that rely on REST-layer authorization.
Transport-level authorization is not affected by this issue.
Impact
The default OpenSearch distribution is not affected by this issue. REST actions in the default distribution have corresponding transport actions that independently enforce authorization. Custom plugins that register REST actions without a corresponding transport action may be affected, potentially allowing unauthorized read access to those endpoints.
Patches
This issue is fixed in OpenSearch 2.19.0. Users should upgrade to 2.19.0 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opensearch.plugin:opensearch-security | ≥ 2.11.0.0&&< 2.19.0.0 | 2.19.0.0org.opensearch.plugin:opensearch-security:2.19.0.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opensearch.plugin:opensearch-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opensearch.plugin:opensearch-security to 2.19.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-83x9-vc3c-hghc is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-83x9-vc3c-hghc in your dependencies?
Find it across Maven, including transitive dependencies.