OpenSearch vulnerable to improper authorization for Rollover RequestsGHSA-22vx-2x23-98w6
LOWGHSA-22vx-2x23-98w6 is a low-severity (CVSS 2.2) vulnerability in org.opensearch.plugin:opensearch-security. A fix is available for org.opensearch.plugin:opensearch-security — see the affected versions and patch details below.
Real-World Exposure
org.opensearch.plugin:opensearch-security☕org.opensearch.plugin:opensearch-securityReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Description
A flaw was identified in the OpenSearch Security plugin's handling of index rollover requests. When a rollover request included an explicit target index name, the security plugin did not properly evaluate access control permissions against the target index. This could allow a user with rollover permissions on a source index to create a new index with a name they are not authorized to use.
Impact
A user with indices:admin/rollover permission on a source index pattern could roll over to a target index name outside their authorized index patterns. This is limited to index creation via the rollover API and requires the user to already have rollover privileges on the source index.
Patches
This issue is fixed in OpenSearch 2.19.4 and 3.2.0
Workarounds
Grant the indices:admin/rollover permission only to fully trusted users.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opensearch.plugin:opensearch-security | ≥ 1.0.0&&< 2.19.4.0 | 2.19.4.0org.opensearch.plugin:opensearch-security:2.19.4.0 |
| ☕Maven | org.opensearch.plugin:opensearch-security | ≥ 3.0.0&&< 3.2.0.0 | 3.2.0.0org.opensearch.plugin:opensearch-security:3.2.0.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opensearch.plugin:opensearch-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opensearch.plugin:opensearch-security to 2.19.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-22vx-2x23-98w6 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-22vx-2x23-98w6 in your dependencies?
Find it across Maven, including transitive dependencies.