OpenSearch unauthorized data access on fields protected by field masking for fields of type ip, geo_point, geo_shape, xy_point, xy_shapeGHSA-rrmm-wq7q-h4v5
MEDIUMGHSA-rrmm-wq7q-h4v5 is a medium-severity (CVSS 5.7) vulnerability in org.opensearch.plugin:opensearch-security. A fix is available for org.opensearch.plugin:opensearch-security — see the affected versions and patch details below.
Real-World Exposure
org.opensearch.plugin:opensearch-securityReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
OpenSearch versions 2.19.2 and earlier improperly apply field masking rules on fields of the types ip, geo_point, geo_shape, xy_point, xy_shape. While the content of these fields is properly redacted in the _source document returned by search operations, the original unredacted values remain available to search queries. This allows to reconstruct the original field contents using range queries.
Additionally, the content of fields of type geo_point, geo_shape, xy_point, xy_shape is returned in an unredacted form if requested via the fields option of the search API.
Patches
The issue has been resolved in OpenSearch 3.0.0 and OpenSearch 2.19.3.
Workarounds
If you cannot upgrade immediately, you can avoid the problem by using field level security (FLS) protection on fields of the affected types instead of field masking.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opensearch.plugin:opensearch-security | all versions | 2.19.3.0org.opensearch.plugin:opensearch-security:2.19.3.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opensearch.plugin:opensearch-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opensearch.plugin:opensearch-security to 2.19.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rrmm-wq7q-h4v5 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-rrmm-wq7q-h4v5 in your dependencies?
Find it across Maven, including transitive dependencies.