NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Craft Commerce has Stored XSS in Inventory Location Address Leading to Potential Privilege EscalationGHSA-wq2m-r96q-crrf

Fix: craftcms/commerce@fa27333

GHSA-wq2m-r96q-crrf is a Cross-site Scripting (XSS) vulnerability in craftcms/commerce. A fix is available for craftcms/commerce — see the affected versions and patch details below.

Also known asCVE-2026-25490
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-wq2m-r96q-crrf.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.05%
Lower risk than most CVEs23th percentile — riskier than 23% of all scored CVEsHighest risk
0.00%0.28%0.57%0.85%0.0%0.3%0.3%0.4%0.3%Jun 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐘craftcms/commerce🐘craftcms/commerce

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A stored XSS vulnerability in Craft Commerce allows attackers to execute malicious JavaScript in an administrator’s browser. This occurs because the 'Address Line 1' field in Inventory Locations is not properly sanitized before being displayed in the admin panel.

Proof of Concept

Required Permissions

  • General permissions:
    • Access the control panel
    • Access Craft Commerce
  • Craft Commerce permissions:
    • Manage inventory locations
  • An active administrator elevated session
<img width="887" height="832" alt="req-perms" src="https://github.com/user-attachments/assets/7a9a5ef6-4fc3-4af1-8ded-08861ead0b7e" />

Steps to Reproduce

  1. Log in to the Admin Panel with the attacker account with the permissions mentioned above.
  2. Navigate to Commerce -> Inventory Locations -> Default (/admin/commerce/inventory-locations/1).
  3. In the Address Line 1 field, enter the following payload:
<img src=x onerror="alert(document.domain)">
  1. Click Save and you'll be redirected back to the Inventory Locations page.
  2. Notice the alert proving JavaScript execution. <img width="1814" height="606" alt="alert-poc" src="https://github.com/user-attachments/assets/f08aed21-a676-4dee-85a8-d195bab85685" />

Privilege Escalation to Administrator:

  1. Do the same steps above, but replace the payload with a malicious one.
  2. The following payload elevates the attacker’s account to Admin if there’s already an elevated session, replace the <UserID> with the attacker id:
<img src=x onerror="fetch('/admin/users/<UserID>/permissions',{method:'POST',body:`CRAFT_CSRF_TOKEN=${Craft.csrfTokenValue}&userId=<UserID>&admin=1&action=users/save-permissions`,headers:{'content-type':'application/x-www-form-urlencoded'}})">
  1. In another browser, log in as an admin & go to the vulnerable page (Inventory Location page).
  2. Go back to the attacker account & notice it now has admin status.

The privilege escalation requires an elevated session. In a real-world scenario, an attacker can automate the process by forcing a logout if the victim’s session is stale; upon re-authentication, the stored XSS payload executes within a fresh elevated session to complete the attack.

Or even easier (and smarter), an attacker (using the XSS) can create a fake 'Session Expired' login modal overlay. Since it’s on the trusted domain, administrators will likely enter their credentials, sending them directly to the attacker.

Resources:

https://github.com/craftcms/commerce/commit/fa273330807807d05b564d37c88654cd772839ee

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcraftcms/commerce≥ 5.0.0-RC1&&< 5.5.25.5.2composer require craftcms/commerce:^5.5.2
🐘Packagistcraftcms/commerce≥ 4.0.0-RC1&&< 4.10.14.10.1composer require craftcms/commerce:^4.10.1

Affected Products

1 product · 4 configurations
Application
craft commercecraftcms
≥ 5.0.0 && < 5.5.2
1 version
4.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/commerce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update craftcms/commerce to 5.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wq2m-r96q-crrf is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

## Summary A stored XSS vulnerability in Craft Commerce allows attackers to execute malicious JavaScript in an administrator’s browser. This occurs because the 'Address Line 1' field in Inventory Locations is not properly sanitized before being displayed in the admin panel. ## Proof of Concept ### Required Permissions - General permissions: - Access the control panel - Access Craft Commerce - Craft Commerce permissions: - Manage inventory locations - An active administrator elevated session <img width="887" height="832" alt="req-perms" src="https://github.com/user-attachments/assets/7a9a
O3 Security · Impact-Aware SCA

Is GHSA-wq2m-r96q-crrf in your dependencies?

Find it across Packagist, including transitive dependencies.

Craft Commerce has Stored XSS in Inventory Location…