CVE-2026-25490 — commerce
Fix: craftcms/commerce@fa27333CVE-2026-25490 is a Cross-site Scripting (XSS) vulnerability in craftcms/commerce. A fix is available for craftcms/commerce — see the affected versions and patch details below.
Craft Commerce has Stored XSS in Inventory Location Address Leading to Potential Privilege Escalation
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25490.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
craftcms/commerce🐘craftcms/commerceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A stored XSS vulnerability in Craft Commerce allows attackers to execute malicious JavaScript in an administrator’s browser. This occurs because the 'Address Line 1' field in Inventory Locations is not properly sanitized before being displayed in the admin panel.
Proof of Concept
Required Permissions
- General permissions:
- Access the control panel
- Access Craft Commerce
- Craft Commerce permissions:
- Manage inventory locations
- An active administrator elevated session
Steps to Reproduce
- Log in to the Admin Panel with the attacker account with the permissions mentioned above.
- Navigate to Commerce -> Inventory Locations -> Default (
/admin/commerce/inventory-locations/1). - In the Address Line 1 field, enter the following payload:
<img src=x onerror="alert(document.domain)">
- Click Save and you'll be redirected back to the Inventory Locations page.
- Notice the alert proving JavaScript execution. <img width="1814" height="606" alt="alert-poc" src="https://github.com/user-attachments/assets/f08aed21-a676-4dee-85a8-d195bab85685" />
Privilege Escalation to Administrator:
- Do the same steps above, but replace the payload with a malicious one.
- The following payload elevates the attacker’s account to Admin if there’s already an elevated session, replace the
<UserID>with the attacker id:
<img src=x onerror="fetch('/admin/users/<UserID>/permissions',{method:'POST',body:`CRAFT_CSRF_TOKEN=${Craft.csrfTokenValue}&userId=<UserID>&admin=1&action=users/save-permissions`,headers:{'content-type':'application/x-www-form-urlencoded'}})">
- In another browser, log in as an admin & go to the vulnerable page (Inventory Location page).
- Go back to the attacker account & notice it now has admin status.
The privilege escalation requires an elevated session. In a real-world scenario, an attacker can automate the process by forcing a logout if the victim’s session is stale; upon re-authentication, the stored XSS payload executes within a fresh elevated session to complete the attack.
Or even easier (and smarter), an attacker (using the XSS) can create a fake 'Session Expired' login modal overlay. Since it’s on the trusted domain, administrators will likely enter their credentials, sending them directly to the attacker.
Resources:
https://github.com/craftcms/commerce/commit/fa273330807807d05b564d37c88654cd772839ee
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | craftcms/commerce | ≥ 5.0.0-RC1&&< 5.5.2 | 5.5.2composer require craftcms/commerce:^5.5.2 |
| 🐘Packagist | craftcms/commerce | ≥ 4.0.0-RC1&&< 4.10.1 | 4.10.1composer require craftcms/commerce:^4.10.1 |
Affected Products
craft commercecraftcmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/commerce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update craftcms/commerce to 5.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25490 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-25490 in your dependencies?
Find it across Packagist, including transitive dependencies.