Apache Tomcat Vulnerable to Relative Path TraversalGHSA-wmwf-9ccg-fff5
HIGHFix: apache/tomcat@130d36dGHSA-wmwf-9ccg-fff5 is a high-severity (CVSS 7.5) CWE-23 vulnerability in org.apache.tomcat:tomcat. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-wmwf-9ccg-fff5.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina+4 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Relative Path Traversal vulnerability in Apache Tomcat.
The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108.
The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 11.0.0-M1&&< 11.0.11 | 11.0.11org.apache.tomcat:tomcat:11.0.11 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 10.1.0-M1&&< 10.1.45 | 10.1.45org.apache.tomcat:tomcat:10.1.45 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.0-M11&&< 9.0.109 | 9.0.109org.apache.tomcat:tomcat:9.0.109 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.5.6 | No fix |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 11.0.0-M1&&< 11.0.11 | 11.0.11org.apache.tomcat:tomcat-catalina:11.0.11 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1&&< 10.1.45 | 10.1.45org.apache.tomcat:tomcat-catalina:10.1.45 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 11.0.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wmwf-9ccg-fff5 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as Important rather than Critical because successful exploitation depends on specific, non-default configuration conditions. The flaw only becomes exploitable when both URL rewriting rules that modify the request path are in use and HTTP PUT requests are enabled — a feature typically…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability. To reduced the risk, by disabling or strictly limiting the use of HTTP PUT requests to trusted, authenticated users only. Additionally, administrators should review and adjust URL rewrite rules to ensure they do not manipulate request paths in ways that could expose protected directories such as /WEB-INF/ or /META-INF/. Implementing strict access controls and monitoring for unexpected rewrite or upload behavior can further minimize potential exploitation.Source: Red Hat security advisory for GHSA-wmwf-9ccg-fff5 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat-1:10.1.36-3.el10_1.1 | RHSA-2025:23050 |
| Red Hat Enterprise Linux 10 | tomcat9-1:9.0.87-8.el10_1.1 | RHSA-2025:23052 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat-1:10.1.36-1.el10_0.3 | RHSA-2025:23051 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat9-1:9.0.87-5.el10_0.4 | RHSA-2025:23053 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.87-1.el8_10.7 | RHSA-2025:23048 |
| Red Hat Enterprise Linux 8.2 Advanced Update Support | pki-deps:10.6-8020020260128173505.4cda2c84 | RHSA-2026:2725 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | pki-deps:10.6-8040020260129154709.522a0ee4 | RHSA-2026:2724 |
| Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support | pki-deps:10.6-8060020260128101437.ad008a3a | RHSA-2026:2726 |
Frequently Asked Questions
Is GHSA-wmwf-9ccg-fff5 in your dependencies?
Find it across Maven, including transitive dependencies.