NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-55955 — tomcat

MEDIUMFix: apache/tomcat@3a9ff01

CVE-2026-55955 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.

Apache Tomcat: EncryptInterceptor not protected against replay attacks

Also known asBIT-tomcat-2026-55955GHSA-c5ph-rghf-fjfj
Published
Updated
Affected
10 pkgs
Patched
6 / 10
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-55955.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.32%0.64%0.97%0.1%0.4%Jul 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

10 pkgs affected
☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat-tribes☕org.apache.tomcat:tomcat-tribes☕org.apache.tomcat:tomcat-tribes+2 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.

Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.

Affected Packages

10 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat≥ 11.0.0-M1&&< 11.0.2311.0.23org.apache.tomcat:tomcat:11.0.23
☕Mavenorg.apache.tomcat:tomcat≥ 10.1.0-M1&&< 10.1.5610.1.56org.apache.tomcat:tomcat:10.1.56
☕Mavenorg.apache.tomcat:tomcat≥ 9.0.13&&< 9.0.1199.0.119org.apache.tomcat:tomcat:9.0.119
☕Mavenorg.apache.tomcat:tomcat≥ 8.5.38No fix
☕Mavenorg.apache.tomcat:tomcat≥ 7.0.100No fix
☕Mavenorg.apache.tomcat:tomcat-tribes≥ 11.0.0-M1&&< 11.0.2311.0.23org.apache.tomcat:tomcat-tribes:11.0.23

Affected Products

1 product · 3 configurations
Application
tomcatapache
≥ 11.0.0 && < 11.0.23
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat to 11.0.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-55955 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

A flaw was found in Apache Tomcat's EncryptionInterceptor used for Tribes cluster communication. An improper authentication vulnerability allows a replay attack against encrypted cluster messages. Exploitation requires the EncryptionInterceptor to be configured for Tomcat clustering, which is a non-default…

Workaround published by Red Hat
This vulnerability only affects Tomcat deployments using the EncryptionInterceptor for Tribes cluster communication. Deployments that do not use Tomcat clustering or do not configure the EncryptionInterceptor are not affected. Ensure cluster communication channels are restricted to trusted, isolated networks.
Source: Red Hat security advisory for CVE-2026-55955 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 10tomcat9-1:9.0.120-1.el10_2RHSA-2026:68651
Red Hat Enterprise Linux 10.0 Extended Update Supporttomcat9-1:9.0.120-1.el10_0RHSA-2026:67163
Red Hat Enterprise Linux 8tomcat-1:9.0.120-1.el8_10RHSA-2026:68677
Red Hat Enterprise Linux 8.8 Telecommunications Update Servicetomcat-1:9.0.120-1.el8_8RHSA-2026:68680
Red Hat Enterprise Linux 9tomcat-1:9.0.120-2.el9_8RHSA-2026:68660
Red Hat Enterprise Linux 9.2 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_2RHSA-2026:68678
Red Hat Enterprise Linux 9.4 Update Services for SAP Solutionstomcat-1:9.0.120-1.el9_4RHSA-2026:68679
Red Hat Enterprise Linux 9.6 Extended Update Supporttomcat-1:9.0.120-1.el9_6RHSA-2026:68659

Frequently Asked Questions

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-55955 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-55955: tomcat Auth Bypass — Fixed in 11.0.23