GHSA-wjxj-f8rg-99wx is a high-severity (CVSS 7.5) CWE-295 vulnerability in org.apache.thrift:libthrift. A fix is available for org.apache.thrift:libthrift — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.thrift:libthrift☕org.apache.thrift:libthriftReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Thrift Java client library versions 0.5.0 prior to 0.9.3-1 and 0.10.0 prior to 0.12.0 can bypass SASL negotiation isComplete validation in the org.apache.thrift.transport.TSaslTransport class. An assert used to determine if the SASL handshake had successfully completed could be disabled in production settings making the validation incomplete.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.thrift:libthrift | ≥ 0.5.0&&< 0.9.3-1 | 0.9.3-1org.apache.thrift:libthrift:0.9.3-1 |
| ☕Maven | org.apache.thrift:libthrift | ≥ 0.10.0&&< 0.12.0 | 0.12.0org.apache.thrift:libthrift:0.12.0 |
Affected Products
thriftapachedebian linuxdebiantraffix signaling delivery controllerf5global lifecycle management opatchoraclenosql databaseoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.thrift:libthrift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.thrift:libthrift to 0.9.3-1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wjxj-f8rg-99wx is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
OpenDaylight: OpenDaylight includes libthrift, however does not use the vulnerable functionality. OpenDaylight should be considered not affected by this flaw.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.4.0 | camel-thrift | RHSA-2019:2413 |
Frequently Asked Questions
Is GHSA-wjxj-f8rg-99wx in your dependencies?
Find it across Maven, including transitive dependencies.