NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-11798 — libthrift

MEDIUMFix: apache/thrift#1606

CVE-2018-11798 is a medium-severity (CVSS 6.5) CWE-538 vulnerability in org.apache.thrift:libthrift. A fix is available for org.apache.thrift:libthrift — see the affected versions and patch details below.

Apache Thrift Node.js static web server sandbox escape

Also known asGHSA-vx85-mj8c-4qm6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%2.07%4.14%6.22%0.4%4.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.thrift:libthrift

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The Apache Thrift Node.js static web server in versions 0.9.2 through 0.11.0 have been determined to contain a security vulnerability in which a remote user has the ability to access files outside the set webservers docroot path.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.thrift:libthrift≥ 0.9.2&&< 0.12.00.12.0org.apache.thrift:libthrift:0.12.0

Affected Products

1 product · 1 configurations
Application
thriftapache
≥ 0.9.2 && ≤ 0.11.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.thrift:libthrift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.thrift:libthrift to 0.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-11798 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

OpenStack and OpenDaylight: The Java implementation of thrift is used in OpenDaylight by parts of the vpnservice functionality. This flaw refers to the JavaScript (node.js) server for Thrift, which is not used or shipped with OpenDaylight or any other part of Red Hat OpenStack Platform.

ProductFixed inAdvisory
Red Hat Fuse 7.3.1camel-thriftRHSA-2019:1545
Red Hat JBoss Data Virtualization 6.4.8libthriftRHSA-2019:3140

Frequently Asked Questions

The Apache Thrift Node.js static web server in versions 0.9.2 through 0.11.0 have been determined to contain a security vulnerability in which a remote user has the ability to access files outside the set webservers docroot path.
O3 Security · Impact-Aware SCA

Is CVE-2018-11798 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-11798: libthrift — Fixed in 0.12.0