NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2026-43869 — libthrift

HIGHFix: apache/thrift@0919c3d

CVE-2026-43869 is a high-severity (CVSS 7.3) CWE-297 vulnerability in org.apache.thrift:libthrift. A fix is available for org.apache.thrift:libthrift — see the affected versions and patch details below.

Apache Thrift: TSSLTransportFactory.java hostname verification

Also known asBIT-thrift-2026-43869GHSA-7pwc-h2j2-rjgj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-43869.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.44%0.87%1.31%0.0%0.6%Jun 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.thrift:libthrift

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.thrift:libthriftall versions0.23.0org.apache.thrift:libthrift:0.23.0

Affected Products

1 product · 1 configurations
Application
thriftapache
< 0.23.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.thrift:libthrift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.thrift:libthrift to 0.23.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-43869 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat rates this vulnerability as Important because missing hostname verification allows an unauthenticated adversary in a man-in-the-middle position to subvert TLS authentication. Within Red Hat environments, Thrift is primarily utilized as an underlying library for inter-service communication across distributed…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for CVE-2026-43869 (CC BY 4.0)
ProductFixed inAdvisory
Cryostat 4 on RHEL 9cryostat/cryostat-storage-rhel9:4.2.0-16RHSA-2026:28010
Red Hat Build of Apache Camel 3.33.2.SP1org.apache.thrift/libthrift:0.23.0RHSA-2026:26586
Multicluster Global Hub 1.3.4multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779212259RHSA-2026:22423
Multicluster Global Hub 1.4.9multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779579439RHSA-2026:22347
Multicluster Global Hub 1.5.8multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1778867753RHSA-2026:21769
Multicluster Global Hub 1.6.6multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1780167118RHSA-2026:23345
Multicluster Global Hub 1.7.3multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779925273RHSA-2026:24503
Red Hat Advanced Cluster Management for Kubernetes 2.13rhacm2/acm-grafana-rhel9:1782383730RHSA-2026:30651

Frequently Asked Questions

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-43869 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-43869: libthrift — Fixed in 0.23.0