Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2026-41603 — libthrift

HIGHFix: apache/thrift@0919c3d

CVE-2026-41603 is a high-severity (CVSS 7.4) vulnerability in org.apache.thrift:libthrift. A fix is available for org.apache.thrift:libthrift — see the affected versions and patch details below.

Apache Thrift: Java TSSLTransportFactory hostname verification

Also known asBIT-thrift-2026-41603GHSA-gf47-qgg5-9g9q
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
☕org.apache.thrift:libthrift

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.thrift:libthriftall versions0.23.0org.apache.thrift:libthrift:0.23.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.thrift:libthrift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.thrift:libthrift to 0.23.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41603 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Multicluster Global Hub 1.3.4multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779212259RHSA-2026:22423
Multicluster Global Hub 1.4.9multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779579439RHSA-2026:22347
Multicluster Global Hub 1.6.5multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1780167118RHSA-2026:23345
Red Hat Advanced Cluster Management for Kubernetes 2.14rhacm2/acm-grafana-rhel9:1782693386RHSA-2026:36882
Red Hat Advanced Cluster Management for Kubernetes 2.15rhacm2/acm-grafana-rhel9:1780677003RHSA-2026:24539
Red Hat multicluster global hub 1.5.3multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1778867753RHSA-2026:21769
Red Hat OpenShift distributed tracing 3.9.3rhosdt/tempo-jaeger-query-rhel9:1778158391RHSA-2026:14885

Frequently Asked Questions

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-41603 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-41603: libthrift — Fixed in 0.23.0