opencv-contrib-python-headless bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863GHSA-w2pj-9cgh-mq2c
HIGHFix: opencv/opencv#24274GHSA-w2pj-9cgh-mq2c is a high-severity (CVSS 8.8) vulnerability in opencv-contrib-python-headless. A fix is available for opencv-contrib-python-headless — see the affected versions and patch details below.
Real-World Exposure
opencv-contrib-python-headlessReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
opencv-contrib-python-headless versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. opencv-contrib-python-headless v4.8.1.78 upgrades the bundled libwebp binary to v1.3.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | opencv-contrib-python-headless | all versions | 4.8.1.78pip install --upgrade 'opencv-contrib-python-headless==4.8.1.78' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opencv-contrib-python-headless, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update opencv-contrib-python-headless to 4.8.1.78 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w2pj-9cgh-mq2c is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-w2pj-9cgh-mq2c in your dependencies?
Find it across PyPI, including transitive dependencies.