NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2019-5064 — opencv-python

HIGH

CVE-2019-5064 is a high-severity (CVSS 8.8) CWE-120 vulnerability in opencv-python. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for opencv-python — see the affected versions and patch details below.

Out-of-bounds Write in OpenCV

Also known asGHSA-q799-q27x-vp7wPYSEC-2026-2802PYSEC-2026-2828PYSEC-2026-2841PYSEC-2026-725
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.22%4.52%8.82%13.1%2.6%10.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐍opencv-python🐍opencv-python-headless🐍opencv-contrib-python🐍opencv-contrib-python-headless

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV, version 4.1.0 (corresponds with OpenCV-Python version 4.1.2.30). A specially crafted JSON file can cause a buffer overflow, resulting in multiple heap corruptions and potentially code execution. An attacker can provide a specially crafted file to trigger this vulnerability.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIopencv-pythonall versions4.2.0.32pip install --upgrade 'opencv-python==4.2.0.32'
🐍PyPIopencv-python-headlessall versions4.2.0.32pip install --upgrade 'opencv-python-headless==4.2.0.32'
🐍PyPIopencv-contrib-pythonall versions4.2.0.32pip install --upgrade 'opencv-contrib-python==4.2.0.32'
🐍PyPIopencv-contrib-python-headlessall versions4.2.0.32pip install --upgrade 'opencv-contrib-python-headless==4.2.0.32'

Affected Products

4 products · 4 configurations
Application
opencvopencv
≥ 4.0.0 && < 4.2.0
range
Application
application testing suiteoracle
1 version
13.3.0.1
Application
big data spatial and graphoracle
< 2.0
range
Application
enterprise manager base platformoracle
1 version
13.4.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opencv-python, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update opencv-python to 4.2.0.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-5064 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

An exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV, version 4.1.0 (corresponds with OpenCV-Python version 4.1.2.30). A specially crafted JSON file can cause a buffer overflow, resulting in multiple heap corruptions and potentially code execution. An attacker can provide a specially crafted file to trigger this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2019-5064 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-5064: opencv-python — Fixed in 4.2.0.32