NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2017-12862 — opencv-python

HIGHFix: opencv/opencv#9376

CVE-2017-12862 is a high-severity (CVSS 8.8) Out-of-bounds Write vulnerability in opencv-python. A fix is available for opencv-python — see the affected versions and patch details below.

Improper Restriction of Operations within the Bounds of a Memory Buffer in OpenCV

Also known asGHSA-5rpc-gwh9-q9fgPYSEC-2026-2807PYSEC-2026-699
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
1.58%2.25%2.92%3.59%2.1%3.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍opencv-python🐍opencv-contrib-python

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

In modules/imgcodecs/src/grfmt_pxm.cpp, the length of buffer AutoBuffer _src is small than expected, which will cause copy buffer overflow later. If the image is from remote, may lead to remote code execution or denial of service. This affects OpenCV 3.3 (corresponding to OpenCV-Python 3.3.0.9) and earlier.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIopencv-pythonall versions3.3.1.11pip install --upgrade 'opencv-python==3.3.1.11'
🐍PyPIopencv-contrib-pythonall versions3.3.1.11pip install --upgrade 'opencv-contrib-python==3.3.1.11'

Affected Products

2 products · 3 configurations
OS
debian linuxdebian
2 versions
8.09.0
Application
opencvopencv
≤ 3.3.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opencv-python, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update opencv-python to 3.3.1.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12862 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

In modules/imgcodecs/src/grfmt_pxm.cpp, the length of buffer AutoBuffer _src is small than expected, which will cause copy buffer overflow later. If the image is from remote, may lead to remote code execution or denial of service. This affects OpenCV 3.3 (corresponding to OpenCV-Python 3.3.0.9) and earlier.
O3 Security · Impact-Aware SCA

Is CVE-2017-12862 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-12862: opencv-python RCE — Fixed in 3.3.1.11