CVE-2017-12864 is a high-severity (CVSS 8.8) CWE-190 vulnerability in opencv-python. A fix is available for opencv-python — see the affected versions and patch details below.
Integer Overflow or Wraparound in OpenCV
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
opencv-python🐍opencv-contrib-pythonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In opencv/modules/imgcodecs/src/grfmt_pxm.cpp, function ReadNumber did not checkout the input length, which lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects OpenCV 3.3 (corresponding with OpenCV-Python version 3.3.0.9) and earlier.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | opencv-python | all versions | 3.3.1.11pip install --upgrade 'opencv-python==3.3.1.11' |
| 🐍PyPI | opencv-contrib-python | all versions | 3.3.1.11pip install --upgrade 'opencv-contrib-python==3.3.1.11' |
Affected Products
debian linuxdebianopencvopencvDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opencv-python, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update opencv-python to 3.3.1.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12864 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Frequently Asked Questions
Is CVE-2017-12864 in your dependencies?
Find it across PyPI, including transitive dependencies.