NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2017-18009 — opencv-python

HIGHFix: opencv/opencv#10480

CVE-2017-18009 is a high-severity (CVSS 7.5) Out-of-bounds Read vulnerability in opencv-python. A fix is available for opencv-python — see the affected versions and patch details below.

Out-of-bounds Read in OpenCV

Also known asGHSA-83rh-hx5x-q9p5PYSEC-2026-2810PYSEC-2026-702
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%1.05%2.10%3.15%0.2%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍opencv-python🐍opencv-contrib-python

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

In OpenCV 3.3.1 (corresponding with OpenCV-Python 3.3.1.11), a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIopencv-pythonall versions3.4.1.15pip install --upgrade 'opencv-python==3.4.1.15'
🐍PyPIopencv-contrib-pythonall versions3.4.1.15pip install --upgrade 'opencv-contrib-python==3.4.1.15'

Affected Products

1 product · 1 configurations
Application
opencvopencv
1 version
3.3.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opencv-python, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update opencv-python to 3.4.1.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-18009 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

In OpenCV 3.3.1 (corresponding with OpenCV-Python 3.3.1.11), a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
O3 Security · Impact-Aware SCA

Is CVE-2017-18009 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-18009: opencv-python — Fixed in 3.4.1.15