CVE-2019-14492 — opencv-python
HIGHCVE-2019-14492 is a high-severity (CVSS 7.5) Out-of-bounds Read vulnerability in opencv-python. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for opencv-python — see the affected versions and patch details below.
Out-of-bounds Read and Out-of-bounds Write in OpenCV
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
opencv-python🐍opencv-python🐍opencv-python-headless🐍opencv-python-headless🐍opencv-contrib-python🐍opencv-contrib-python🐍opencv-contrib-python-headless🐍opencv-contrib-python-headlessReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in OpenCV before 3.4.7 and 4.x before 4.1.1 (OpenCV-Python before 3.4.7.28 and 4.x before 4.1.1.26). There is an out of bounds read/write in the function HaarEvaluator::OptFeature::calc in modules/objdetect/src/cascadedetect.hpp, which leads to denial of service.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | opencv-python | all versions | 3.4.7.28pip install --upgrade 'opencv-python==3.4.7.28' |
| 🐍PyPI | opencv-python | ≥ 4.0.0.21&&< 4.1.1.26 | 4.1.1.26pip install --upgrade 'opencv-python==4.1.1.26' |
| 🐍PyPI | opencv-python-headless | all versions | 3.4.7.28pip install --upgrade 'opencv-python-headless==3.4.7.28' |
| 🐍PyPI | opencv-python-headless | ≥ 4.0.0.21&&< 4.1.1.26 | 4.1.1.26pip install --upgrade 'opencv-python-headless==4.1.1.26' |
| 🐍PyPI | opencv-contrib-python | all versions | 3.4.7.28pip install --upgrade 'opencv-contrib-python==3.4.7.28' |
| 🐍PyPI | opencv-contrib-python | ≥ 4.0.0.21&&< 4.1.1.26 | 4.1.1.26pip install --upgrade 'opencv-contrib-python==4.1.1.26' |
Affected Products
opencvopencvleapopensuseResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opencv-python, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update opencv-python to 3.4.7.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14492 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The versions of OpenCV as shipped with Red Hat Enterprise Linux 7 and 8 are affected by this flaw. Although it's technically possible that classifiers are loaded from untrusted sources, this is probably an unlikely case in practice.
Avoid loading cascade classifiers from external untrusted sources.Source: Red Hat security advisory for CVE-2019-14492 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2019-14492 in your dependencies?
Find it across PyPI, including transitive dependencies.