NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

django-mfa2 vulnerable to MFA Replay attackGHSA-vw39-2wj9-4q86

HIGHFix: mkalioby/django-mfa2@54db5a5

GHSA-vw39-2wj9-4q86 is a high-severity (CVSS 7.5) CWE-294 vulnerability in django-mfa2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for django-mfa2 — see the affected versions and patch details below.

Also known asCVE-2022-42731PYSEC-2022-303
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 8, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-vw39-2wj9-4q86.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.67%1.34%2.01%0.4%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍django-mfa2🐍django-mfa2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

mfa/FIDO2.py in django-mfa2 before 2.5.1 and 2.6.x before 2.6.1 allows a replay attack that could be used to register another device for a user. The device registration challenge is not invalidated after usage.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango-mfa2all versions2.5.1pip install --upgrade 'django-mfa2==2.5.1'
🐍PyPIdjango-mfa2≥ 2.6.0&&< 2.6.12.6.1pip install --upgrade 'django-mfa2==2.6.1'

Affected Products

1 product · 2 configurations
Application
django-mfa2django-mfa2_project
≥ 2.6.0 && < 2.6.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django-mfa2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django-mfa2 to 2.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vw39-2wj9-4q86 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

mfa/FIDO2.py in django-mfa2 before 2.5.1 and 2.6.x before 2.6.1 allows a replay attack that could be used to register another device for a user. The device registration challenge is not invalidated after usage.
O3 Security · Impact-Aware SCA

Is GHSA-vw39-2wj9-4q86 in your dependencies?

Find it across PyPI, including transitive dependencies.

django-mfa2 vulnerable to MFA Replay attack (High 7.5)