CVE-2026-69206 is a medium-severity (CVSS 5.9) CWE-294 vulnerability in org.http4s:http4s-ember-core_2.12. A fix is available for org.http4s:http4s-ember-core_2.12 — see the affected versions and patch details below.
Http4s: DigestAuth allows replay of captured requests
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-69206.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.http4s:http4s-ember-core_2.12☕org.http4s:http4s-ember-core_2.13☕org.http4s:http4s-ember-core_3☕org.http4s:http4s-ember-core_2.13☕org.http4s:http4s-ember-core_3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The DigestAuth replay defence stores lastNc + 1 rather than the nonce-count (nc) value it just accepted. When a legitimate client sends non-contiguous nc values (parallel or retried requests, as browsers do), the server's counter lags behind the highest nc seen, and a captured Authorization header can be replayed multiple times.
Impact
A passive observer can turn one captured Digest-authenticated request into several replayed authenticated (state-changing) requests, defeating the core replay protection Digest provides over Basic.
Preconditions
- Application uses
DigestAuth. - Attacker can passively observe at least one legitimate digest request.
- Legitimate client emits an
ncmore than one greater than the last, for instance from a parallel or retried request.
Workarounds
- Deploy over TLS so requests cannot be captured.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.http4s:http4s-ember-core_2.12 | all versions | 0.23.35org.http4s:http4s-ember-core_2.12:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_2.13 | all versions | 0.23.35org.http4s:http4s-ember-core_2.13:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_3 | all versions | 0.23.35org.http4s:http4s-ember-core_3:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_2.13 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-core_2.13:1.0.0-M47 |
| ☕Maven | org.http4s:http4s-ember-core_3 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-core_3:1.0.0-M47 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.http4s:http4s-ember-core_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.http4s:http4s-ember-core_2.12 to 0.23.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-69206 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-69206 in your dependencies?
Find it across Maven, including transitive dependencies.