CVE-2026-69216 is a medium-severity (CVSS 5.4) CWE-444 vulnerability in org.http4s:http4s-ember-core_2.12. A fix is available for org.http4s:http4s-ember-core_2.12 — see the affected versions and patch details below.
Http4s: Ember chunk parser lenience (TE.TE request smuggling)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-69216.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2026-69216 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 397,508 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
org.http4s:http4s-ember-core_2.12☕org.http4s:http4s-ember-core_2.13☕org.http4s:http4s-ember-core_3☕org.http4s:http4s-ember-core_2.13☕org.http4s:http4s-ember-core_3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Ember's chunk decoder parses the size token leniently: it strips leading and trailing whitespace and accepts a leading + or - sign. RFC9112 §7.1 defines chunk-size = 1*HEXDIG. An intermediary that parses the chunk boundary differently (or rejects it) will disagree with Ember on request framing, enabling HTTP request smuggling (TE.TE).
Impact
Server
Request smuggling (TE.TE) when ember-server is an origin behind an intermediary that forwards the body verbatim but interprets the malformed chunk sizes differently
- Front-end security bypass: the smuggled request reaches paths the intermediary might have blocked, with attacker-chosen method and headers.
- Cache poisoning: the smuggled response is associated with the next request key in a caching proxy.
- Request queue hijack:
Client
ember-client has the same leniencies on the response path, which enables response smuggling when http4s is used as a gateway. This is less severe, as it requires a malicious or compromised upstream rather than an anonymous remote client.
Preconditions
- Unauthenticated remote attacker (server)
- ember-server as origin behind a keep-alive intermediary
- Malicious or compromised upstream (client)
- Intermediary or upstream forwards chunked bodies without re-encoding and disagrees with Ember on
+prefix,-prefix, or leading and trailing octets rather than rejecting.
Workarounds
- Intermediary strictly rejects malformed chunk sizes
- Intermediary buffers and re-encodes request bodies
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.http4s:http4s-ember-core_2.12 | all versions | 0.23.35org.http4s:http4s-ember-core_2.12:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_2.13 | all versions | 0.23.35org.http4s:http4s-ember-core_2.13:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_3 | all versions | 0.23.35org.http4s:http4s-ember-core_3:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_2.13 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-core_2.13:1.0.0-M47 |
| ☕Maven | org.http4s:http4s-ember-core_3 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-core_3:1.0.0-M47 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.http4s:http4s-ember-core_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.http4s:http4s-ember-core_2.12 to 0.23.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-69216 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-69216 in your dependencies?
Find it across Maven, including transitive dependencies.