CVE-2026-69204 — http4s-ember-core_2.12
Fix: http4s/http4s@9feaf86CVE-2026-69204 is a CWE-444 vulnerability in org.http4s:http4s-ember-core_2.12. A fix is available for org.http4s:http4s-ember-core_2.12 — see the affected versions and patch details below.
Http4s: Ember accepts Transfer-Encoding combined with Content-Length (CL.TE request smuggling)
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-69204.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.http4s:http4s-ember-core_2.12☕org.http4s:http4s-ember-core_2.13☕org.http4s:http4s-ember-core_3☕org.http4s:http4s-ember-core_2.13☕org.http4s:http4s-ember-core_3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Ember's HTTP/1.1 request parser does not reject a message that carries both a
Transfer-Encoding and a Content-Length header. RFC 9112 §6.1 requires a
server to treat such a message as a framing error and close the connection.
An intermediary that follows the RFC's CL-strip-and-forward path (or that
prioritises Content-Length) will frame the body differently from Ember,
enabling HTTP request smuggling (CL.TE).
Impact
Server
Request smuggling when ember-server is an origin behind an intermediary that
forwards both headers over a keep-alive backend connection and frames by
Content-Length while Ember frames by chunked:
- Front-end security bypass: the smuggled request reaches paths the intermediary's ACL/auth layer would have blocked, with attacker-chosen method and headers.
- Cross-user request hijack: a dangling smuggled prefix concatenates with the next victim's request on the shared backend socket, capturing its headers.
- Cache poisoning: the smuggled response is associated with the next request key in a caching proxy.
Client
ember-client shares the same parser on the response path. An upstream that sends both headers can desync a pooled client connection. This requires a malicious or compromised upstream.
Preconditions
- Unauthenticated remote attacker (server)
- ember-server as origin behind a keep-alive intermediary
- Intermediary forwards a request carrying both
Transfer-EncodingandContent-Length(RFC says it MAY reject; many forward) and frames byContent-Length - Malicious or compromised upstream (client)
Workarounds
- Intermediary strictly rejects requests carrying both
Transfer-EncodingandContent-Length - Intermediary buffers and re-encodes request bodies
- Disable backend keep-alive between the intermediary and Ember
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.http4s:http4s-ember-core_2.12 | all versions | 0.23.35org.http4s:http4s-ember-core_2.12:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_2.13 | all versions | 0.23.35org.http4s:http4s-ember-core_2.13:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_3 | all versions | 0.23.35org.http4s:http4s-ember-core_3:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_2.13 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-core_2.13:1.0.0-M47 |
| ☕Maven | org.http4s:http4s-ember-core_3 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-core_3:1.0.0-M47 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.http4s:http4s-ember-core_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.http4s:http4s-ember-core_2.12 to 0.23.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-69204 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-69204 in your dependencies?
Find it across Maven, including transitive dependencies.