CVE-2022-42731 is a high-severity (CVSS 7.5) CWE-294 vulnerability in django-mfa2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for django-mfa2 — see the affected versions and patch details below.
django-mfa2 vulnerable to MFA Replay attack
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-42731.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django-mfa2🐍django-mfa2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
mfa/FIDO2.py in django-mfa2 before 2.5.1 and 2.6.x before 2.6.1 allows a replay attack that could be used to register another device for a user. The device registration challenge is not invalidated after usage.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django-mfa2 | all versions | 2.5.1pip install --upgrade 'django-mfa2==2.5.1' |
| 🐍PyPI | django-mfa2 | ≥ 2.6.0&&< 2.6.1 | 2.6.1pip install --upgrade 'django-mfa2==2.6.1' |
Affected Products
django-mfa2django-mfa2_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django-mfa2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django-mfa2 to 2.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-42731 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-42731 in your dependencies?
Find it across PyPI, including transitive dependencies.