Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4JGHSA-vjwc-5hfh-2vv5
HIGHFix: apache/ws-wss4j@970b3e3GHSA-vjwc-5hfh-2vv5 is a high-severity (CVSS 7.5) Broken Cryptographic Algorithm vulnerability in org.apache.ws.security:wss4j. A fix is available for org.apache.ws.security:wss4j — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.ws.security:wss4j☕org.apache.wss4j:wss4j-ws-security-domReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key or message data, which makes it easier for remote attackers to recover the plaintext form of a symmetric key via a series of crafted messages. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-2487.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.ws.security:wss4j | all versions | 1.6.17org.apache.ws.security:wss4j:1.6.17 |
| ☕Maven | org.apache.wss4j:wss4j-ws-security-dom | ≥ 2.0.0&&< 2.0.2 | 2.0.2org.apache.wss4j:wss4j-ws-security-dom:2.0.2 |
Affected Products
wss4japacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.ws.security:wss4j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.ws.security:wss4j to 1.6.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vjwc-5hfh-2vv5 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.2 | see advisory | RHSA-2015:1177 |
| Red Hat JBoss Data Grid 6.4 | wss4j | RHSA-2015:0773 |
| Red Hat JBoss Enterprise Application Platform 6.4 | see advisory | RHSA-2015:0849 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 | apache-commons-cli-eap6-0:1.2.0-1.redhat_8.1.ep6.el5 | RHSA-2015:0846 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | apache-commons-cli-eap6-0:1.2.0-1.redhat_8.1.ep6.el6 | RHSA-2015:0847 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 | apache-commons-daemon-eap6-1:1.0.15-8.redhat_1.ep6.el7 | RHSA-2015:0848 |
| Red Hat JBoss Fuse 6.2 | see advisory | RHSA-2015:1176 |
| Red Hat JBoss Portal 6.2 | see advisory | RHSA-2015:1009 |
Frequently Asked Questions
Is GHSA-vjwc-5hfh-2vv5 in your dependencies?
Find it across Maven, including transitive dependencies.