CVE-2011-2487 — wss4j
MEDIUMCVE-2011-2487 is a medium-severity (CVSS 5.9) Broken Cryptographic Algorithm vulnerability in org.apache.ws.security:wss4j. A fix is available for org.apache.ws.security:wss4j — see the affected versions and patch details below.
Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.ws.security:wss4j☕wss4j:wss4jReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The implementations of PKCS#1 v1.5 key transport mechanism for XMLEncryption in JBossWS and Apache WSS4J before 1.6.5 is susceptible to a Bleichenbacher attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.ws.security:wss4j | all versions | 1.6.5org.apache.ws.security:wss4j:1.6.5 |
| ☕Maven | wss4j:wss4j | all versions | 1.6.5wss4j:wss4j:1.6.5 |
Affected Products
cxfapachewss4japachejboss business rules management systemredhatjboss enterprise application platformredhatjboss enterprise application platform text-only advisoriesredhatjboss enterprise soa platformredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.ws.security:wss4j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.ws.security:wss4j to 1.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-2487 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This flaw affects Apache CXF (WSS4J) and jbossws-native as shipped with various JBoss products. It does not affect JBoss Enterprise Application Platform 6 and JBoss Application Server 7.1.1 and above. These products include WSS4J 1.6.5, which incorporates a fix for this flaw. On affected products, this flaw can be…
| Product | Fixed in | Advisory |
|---|---|---|
| JBEWP 5 for RHEL 5 | aopalliance-0:1.0-5.2.jdk6.ep5.el5 | RHSA-2013:0196 |
| JBEWP 5 for RHEL 6 | aopalliance-0:1.0-5.3.ep5.el6 | RHSA-2013:0195 |
| JBoss Enterprise BRMS Platform 5.3 | see advisory | RHSA-2013:0221 |
| Red Hat JBoss Enterprise Application Platform 5.2 | see advisory | RHSA-2013:0194 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 5 | aopalliance-0:1.0-5.2.jdk6.ep5.el5 | RHSA-2013:0192 |
| Red Hat JBoss Enterprise Application Platform 5 for RHEL 6 | aopalliance-0:1.0-5.3.ep5.el6 | RHSA-2013:0191 |
| Red Hat JBoss Portal 5.2 | see advisory | RHSA-2013:0953 |
| Red Hat JBoss SOA Platform 5.3 | see advisory | RHSA-2013:0533 |
Frequently Asked Questions
Is CVE-2011-2487 in your dependencies?
Find it across Maven, including transitive dependencies.