NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2015-0227 — wss4j

CVE-2015-0227 is a CWE-264 vulnerability in org.apache.ws.security:wss4j. A fix is available for org.apache.ws.security:wss4j — see the affected versions and patch details below.

Improper Access Control in Apache WSS4J

Also known asGHSA-6r5v-hp32-fjqw
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
5.64%9.02%12.4%15.8%13.9%7.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
☕org.apache.ws.security:wss4j☕org.apache.ws.security:wss4j☕wss4j:wss4j

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.ws.security:wss4jall versions1.6.17org.apache.ws.security:wss4j:1.6.17
☕Mavenorg.apache.ws.security:wss4j≥ 2.0.0&&< 2.022.02org.apache.ws.security:wss4j:2.02
☕Mavenwss4j:wss4jall versions1.6.17wss4j:wss4j:1.6.17

Affected Products

1 product · 4 configurations
Application
wss4japache
≤ 1.6.16
2 versions
2.0.02.0.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.ws.security:wss4j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.ws.security:wss4j to 1.6.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-0227 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat JBoss A-MQ 6.2see advisoryRHSA-2015:1177
Red Hat JBoss Data Grid 6.4wss4jRHSA-2015:0773
Red Hat JBoss Enterprise Application Platform 6.4see advisoryRHSA-2015:0849
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5apache-commons-cli-eap6-0:1.2.0-1.redhat_8.1.ep6.el5RHSA-2015:0846
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6apache-commons-cli-eap6-0:1.2.0-1.redhat_8.1.ep6.el6RHSA-2015:0847
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7apache-commons-daemon-eap6-1:1.0.15-8.redhat_1.ep6.el7RHSA-2015:0848
Red Hat JBoss Fuse 6.2see advisoryRHSA-2015:1176
Red Hat JBoss Portal 6.2see advisoryRHSA-2015:1009

Frequently Asked Questions

Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."
O3 Security · Impact-Aware SCA

Is CVE-2015-0227 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2015-0227: wss4j — Fixed in 1.6.17