CVE-2014-3623 — wss4j
CVE-2014-3623 is a Improper Authentication vulnerability in org.apache.ws.security:wss4j. A fix is available for org.apache.ws.security:wss4j — see the affected versions and patch details below.
Improper Authentication in Apache WSS4J
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.ws.security:wss4j☕org.apache.wss4j:wss4j-ws-security-domReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.ws.security:wss4j | all versions | 1.6.17org.apache.ws.security:wss4j:1.6.17 |
| ☕Maven | org.apache.wss4j:wss4j-ws-security-dom | ≥ 2.0.0&&< 2.0.2 | 2.0.2org.apache.wss4j:wss4j-ws-security-dom:2.0.2 |
Affected Products
cxfapachewss4japacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.ws.security:wss4j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.ws.security:wss4j to 1.6.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3623 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Fuse ESB Enterprise 7 is now in Maintenance Support phase receiving only qualified Important and Critical impact security fixes. This issue has been rated as having Moderate security impact and is not currently planned to be addressed in future updates. For additional information, refer to the Fuse Product Life Cycle:…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.1 | see advisory | RHSA-2015:0236 |
| Red Hat JBoss BPMS 6.0 | see advisory | RHSA-2015:0851 |
| Red Hat JBoss BRMS 6.0 | see advisory | RHSA-2015:0850 |
| Red Hat JBoss Data Virtualization 6.1 | see advisory | RHSA-2015:0675 |
| Red Hat JBoss Enterprise Application Platform 6.3 | see advisory | RHSA-2014:2020 |
| Red Hat JBoss Enterprise Application Platform 6.3 for RHEL 5 | apache-cxf-0:2.7.12-1.SP1_redhat_5.1.ep6.el5 | RHSA-2014:2019 |
Frequently Asked Questions
Is CVE-2014-3623 in your dependencies?
Find it across Maven, including transitive dependencies.