NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Plaintext storage of tokens in pulp_ansibleGHSA-qv37-mfjf-42h8

MEDIUMFix: pulp/pulp_ansible@d13c427

GHSA-qv37-mfjf-42h8 is a medium-severity (CVSS 5.5) CWE-256 vulnerability in pulp-ansible. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for pulp-ansible — see the affected versions and patch details below.

Also known asCVE-2022-3644PYSEC-2026-900
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-qv37-mfjf-42h8.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs23th percentile — riskier than 23% of all scored CVEsHighest risk
0.00%0.27%0.53%0.80%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pulp-ansible

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The collection remote for pulp_ansible stores tokens in plaintext instead of using pulp's encrypted field and exposes them in read/write mode via the API () instead of marking it as write only.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpulp-ansibleall versions0.15.0pip install --upgrade 'pulp-ansible==0.15.0'

Affected Products

4 products · 4 configurations
Application
pulp ansiblepulpproject
all
Application
ansible automation platformredhat
1 version
2.0
Application
satelliteredhat
1 version
6.0
Application
update infrastructureredhat
1 version
3.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pulp-ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pulp-ansible to 0.15.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qv37-mfjf-42h8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Satellite 6.14 for RHEL 8python-pulp-ansible-1:0.16.0-1.el8pcRHSA-2023:6818

Frequently Asked Questions

The collection remote for pulp_ansible stores tokens in plaintext instead of using pulp's encrypted field and exposes them in read/write mode via the API () instead of marking it as write only.
O3 Security · Impact-Aware SCA

Is GHSA-qv37-mfjf-42h8 in your dependencies?

Find it across PyPI, including transitive dependencies.

Plaintext storage of tokens in pulp_ansible (Medium 5.5)