CVE-2022-3644 is a medium-severity (CVSS 5.5) CWE-256 vulnerability in pulp-ansible. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for pulp-ansible — see the affected versions and patch details below.
Plaintext storage of tokens in pulp_ansible
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3644.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pulp-ansibleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The collection remote for pulp_ansible stores tokens in plaintext instead of using pulp's encrypted field and exposes them in read/write mode via the API () instead of marking it as write only.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pulp-ansible | all versions | 0.15.0pip install --upgrade 'pulp-ansible==0.15.0' |
Affected Products
pulp ansiblepulpprojectansible automation platformredhatsatelliteredhatupdate infrastructureredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pulp-ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pulp-ansible to 0.15.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3644 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.14 for RHEL 8 | python-pulp-ansible-1:0.16.0-1.el8pc | RHSA-2023:6818 |
Frequently Asked Questions
Is CVE-2022-3644 in your dependencies?
Find it across PyPI, including transitive dependencies.