NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Froala WYSIWYG Editor XSS VulnerabilityGHSA-qrhq-x7xh-2784

MEDIUM

GHSA-qrhq-x7xh-2784 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in froala/wysiwyg-editor. A fix is available for froala/wysiwyg-editor — see the affected versions and patch details below.

Also known asCVE-2020-26523
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.39%0.79%1.19%0.4%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘froala/wysiwyg-editor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Froala Editor before 3.2.2 allows XSS via pasted content.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistfroala/wysiwyg-editorall versions3.2.2composer require froala/wysiwyg-editor:^3.2.2

Affected Products

1 product · 1 configurations
Application
froala editorfroala
< 3.2.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for froala/wysiwyg-editor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update froala/wysiwyg-editor to 3.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qrhq-x7xh-2784 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Froala Editor before 3.2.2 allows XSS via pasted content.
O3 Security · Impact-Aware SCA

Is GHSA-qrhq-x7xh-2784 in your dependencies?

Find it across Packagist, including transitive dependencies.

Froala WYSIWYG Editor XSS Vulnerability (Medium 6.1)