NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-28114 — wysiwyg-editor

MEDIUM

CVE-2021-28114 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in froala/wysiwyg-editor. EPSS puts its 30-day exploitation probability at 52.0% (99th percentile). A fix is available for froala/wysiwyg-editor — see the affected versions and patch details below.

Cross-site Scripting in Froala WYSIWYG Editor

Also known asGHSA-rr6v-h7m8-wc9f
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
52.0%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%22.5%45.0%67.5%0.6%52.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘froala/wysiwyg-editor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistfroala/wysiwyg-editorall versions3.2.7composer require froala/wysiwyg-editor:^3.2.7

Affected Products

1 product · 1 configurations
Application
froala editorfroala
< 3.2.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for froala/wysiwyg-editor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update froala/wysiwyg-editor to 3.2.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-28114 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.
O3 Security · Impact-Aware SCA

Is CVE-2021-28114 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-28114: wysiwyg-editor XSS — Fixed in 3.2.7