NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-41592 — froala-editor

MEDIUM

CVE-2023-41592 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in froala-editor. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for froala-editor — see the affected versions and patch details below.

Froala Editor Cross-site Scripting vulnerability

Also known asGHSA-hvpq-7vcc-5hj5
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-41592.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.39%1.17%1.95%2.73%2.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

195other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
froala-editornpm
519Kdownloads / week

Description

Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmfroala-editor≥ 4.0.1&&< 4.1.44.1.4npm install froala-editor@4.1.4
🐘Packagistfroala/wysiwyg-editor≥ 4.0.1&&< 4.1.44.1.4composer require froala/wysiwyg-editor:^4.1.4

Affected Products

1 product · 1 configurations
Application
froala editorfroala
≥ 4.0.1 && ≤ 4.1.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for froala-editor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update froala-editor to 4.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-41592 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2023-41592 in your dependencies?

Find it across npm, Packagist, including transitive dependencies.

CVE-2023-41592: froala-editor XSS — Fixed in 4.1.4