GHSA-q4m3-2j7h-f7xw is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars.npm:jquery. 2 public exploit references exist, so weaponization risk is real. A fix is available for org.webjars.npm:jquery — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
GHSA-q4m3-2j7h-f7xw by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 397,508 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
jquerynpmDescription
Versions of jquery prior to 1.9.0 are vulnerable to Cross-Site Scripting. The load method fails to recognize and remove <script> HTML tags that contain a whitespace character, i.e: </script >, which results in the enclosed script logic to be executed. This allows attackers to execute arbitrary JavaScript in a victim's browser.
Recommendation
Upgrade to version 1.9.0 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.webjars.npm:jquery | ≥ 1.2.1&&< 1.9.0 | 1.9.0org.webjars.npm:jquery:1.9.0 |
| 📦npm | jquery | ≥ 1.2.1&&< 1.9.0 | 1.9.0npm install jquery@1.9.0 |
| .NETNuGet | jQuery | ≥ 1.2.1&&< 1.9.0 | 1.9.0dotnet add package jQuery --version 1.9.0 |
| 💎RubyGems | jquery-rails | all versions | 2.2.0bundle update jquery-rails --conservative |
Affected Products
jqueryjqueryjunosjuniperactive iq unified managernetappcloud backupnetapponcommand system managernetappsnap creator frameworknetappResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
jQuery 3.3.1 - Prototype Pollution & XSS Exploit
by xOryus · Apr 8, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jquery, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.webjars.npm:jquery to 1.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q4m3-2j7h-f7xw is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Enterprise Linux version 6, 7 and 8 ship a vulnerable version of JQuery in the `pcs` component. However the vulnerable has not been found to be exploitable in reasonable scenarios. A future update may update JQuery to a fixed version.
| Product | Fixed in | Advisory |
|---|---|---|
| A-MQ Interconnect 1.y for RHEL 6 | qpid-dispatch-0:1.13.0-3.el6_10 | RHSA-2020:4211 |
| Red Hat Enterprise Linux 8 | pcs-0:0.10.10-4.el8 | RHSA-2021:4142 |
Frequently Asked Questions
Is GHSA-q4m3-2j7h-f7xw in your dependencies?
Find it across Maven, npm, NuGet, including transitive dependencies.