NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

PrestaShop Product Comments Cross-site Scripting vulnerabilityGHSA-prrh-qvhf-x788

MEDIUMFix: PrestaShop/productcomments@314456d

GHSA-prrh-qvhf-x788 is a medium-severity (CVSS 4.3) Cross-site Scripting (XSS) vulnerability in prestashop/productcomments. A fix is available for prestashop/productcomments — see the affected versions and patch details below.

Also known asCVE-2022-35933
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-prrh-qvhf-x788.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.35%0.71%1.06%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘prestashop/productcomments

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

An attacker could steal an admin's cookie

Patches

The issue is fixed in 5.0.2

References

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistprestashop/productcommentsall versions5.0.2composer require prestashop/productcomments:^5.0.2

Affected Products

1 product · 1 configurations
Application
productcommentsprestashop
< 5.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/productcomments, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update prestashop/productcomments to 5.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-prrh-qvhf-x788 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact An attacker could steal an admin's cookie ### Patches The issue is fixed in 5.0.2 ### References [Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')](https://cwe.mitre.org/data/definitions/79.html)
O3 Security · Impact-Aware SCA

Is GHSA-prrh-qvhf-x788 in your dependencies?

Find it across Packagist, including transitive dependencies.

PrestaShop Product Comments Cross-site Scripting…