CVE-2020-26225 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in prestashop/productcomments. A fix is available for prestashop/productcomments — see the affected versions and patch details below.
Reflected XSS with parameters in PostComment
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
prestashop/productcommentsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In PrestaShop Product Comments before version 4.2.0, an attacker could inject malicious web code into the users' web browsers by creating a malicious link. The problem was introduced in version 4.0.0 and is fixed in 4.2.0
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | prestashop/productcomments | ≥ 4.0.0&&< 4.2.0 | 4.2.0composer require prestashop/productcomments:^4.2.0 |
Affected Products
product commentsprestashopDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/productcomments, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update prestashop/productcomments to 4.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-26225 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-26225 in your dependencies?
Find it across Packagist, including transitive dependencies.