NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2020-26248 — productcomments

HIGHFix: PrestaShop/productcomments@7c2033d

CVE-2020-26248 is a high-severity (CVSS 8.2) SQL Injection vulnerability in prestashop/productcomments. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for prestashop/productcomments — see the affected versions and patch details below.

Blind SQL injection in PrestaShop productcomments module

Also known asGHSA-5v44-7647-xfw9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
12.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.00%32.3%64.6%96.9%77.4%12.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘prestashop/productcomments

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In the PrestaShop module "productcomments" before version 4.2.1, an attacker can use a Blind SQL injection to retrieve data or stop the MySQL service. The problem is fixed in 4.2.1 of the module.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistprestashop/productcomments≥ 4.0.0&&< 4.2.14.2.1composer require prestashop/productcomments:^4.2.1

Affected Products

1 product · 1 configurations
Application
productcommentsprestashop
< 4.2.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/productcomments, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update prestashop/productcomments to 4.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-26248 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

How to detect CVE-2020-26248

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2020-26248 -u https://target
Template
PrestaShop Product Comments <4.2.0 - SQL Injection
Severity
high
Impact
Successful exploitation of this vulnerability allows an attacker to execute arbitrary SQL queries, potentially leading to unauthorized access, data leakage, or data manipulation.
Remediation
Fixed in 4.2.1.

Template by ProjectDiscovery nuclei-templates (edoardottt), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

In the PrestaShop module "productcomments" before version 4.2.1, an attacker can use a Blind SQL injection to retrieve data or stop the MySQL service. The problem is fixed in 4.2.1 of the module.
O3 Security · Impact-Aware SCA

Is CVE-2020-26248 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-26248: productcomments — Fixed in 4.2.1