Ez Platform and Legacy are prone to an insecure interpretation of PHP/PHAR uploadsGHSA-pqjm-xcp8-wgmm
Fix: ezsystems/ezplatform@9a0c52dGHSA-pqjm-xcp8-wgmm is a remote code execution vulnerability in ezsystems/ezpublish-legacy. A fix is available for ezsystems/ezpublish-legacy — see the affected versions and patch details below.
Real-World Exposure
ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The eZ Platform and Legacy are affected by an issue related to how uploaded PHP and PHAR files are handled, and consists of two parts: 1. Web server configuration, and 2. Disabling the PHAR stream wrapper.
1. WEB SERVER CONFIGURATION The sample web server configuration in our documentation can in some cases allow the execution of uploaded PHP/PHAR code. This can be abused to allow priviledge escalation and breach of content access controls, among other things. Please ensure that your web server will not execute files in directories were files may be uploaded, such as web/var/ and ezpublish_legacy/var/
As an example, here is how you can make Apache return HTTP 403 Forbidden for a number of executable file types in your eZ Platform var directory. Please adapt it to your needs. It is then possible to enable logging of HTTP 403 in a separate log file if you wish, you could do this to see if someone is trying to abuse the server.
RewriteEngine On
# disable .php(3) and other extensions in the var directory
RewriteRule ^var/.*(?i)\.(php3?|phar|phtml|sh|exe|pl|bin)$ - [F]
Here is the same configuration, but for the Nginx web server:
location ~ ^/var/.*(?i)\.(php3?|phar|phtml|sh|exe|pl|bin)$ {
return 403;
}
2. DISABLE PHAR STREAM WRAPPER PHAR archives may be crafted such that its stream wrapper will execute them without being specifically asked to. With such files, any PHP file operation may cause deserialisation and execution. This may happen even if the file name suffix isn't ".phar". Any site that allows file uploads is at risk. Normally eZ Platform has no need for PHAR support. It's only used by Composer, and that is executed separately from eZ Platform. So one way to avoid this vulnerability is to disable the PHAR stream wrapper within eZ Platform. (If you know you need PHAR support, please consider other means to deal with this vulnerability. For example, enabling the wrapper only in those scripts/bundles that have to deal with such files.)
Disabling the stream wrapper should be done in:
eZ Platform (web/app.php) CLI scripts (bin/console) Legacy (index.php and CLI scripts)
To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply these patches manually: https://github.com/ezsystems/ezplatform/commit/9a0c52dc4535e4b3ce379f80222dc53f705a2cfd https://github.com/ezsystems/ezpublish-legacy/commit/d21957bf202b091ab39dfb5be300f6c30be3933e
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 2018.9.0&&< 2018.9.1.3 | 2018.9.1.3composer require ezsystems/ezpublish-legacy:^2018.9.1.3 |
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 2018.6.0&&< 2018.6.1.4 | 2018.6.1.4composer require ezsystems/ezpublish-legacy:^2018.6.1.4 |
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 2011.0.0&&< 2017.12.4.3 | 2017.12.4.3composer require ezsystems/ezpublish-legacy:^2017.12.4.3 |
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 5.4.0&&< 5.4.12.3 | 5.4.12.3composer require ezsystems/ezpublish-legacy:^5.4.12.3 |
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 5.3.0&&< 5.3.12.6 | 5.3.12.6composer require ezsystems/ezpublish-legacy:^5.3.12.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezpublish-legacy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ezsystems/ezpublish-legacy to 2018.9.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pqjm-xcp8-wgmm is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-pqjm-xcp8-wgmm in your dependencies?
Find it across Packagist, including transitive dependencies.