NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

eZ Publish Legacy Passwordless login for LDAP usersGHSA-p9mp-vq4v-v5m5

Fix: ezsystems/ezpublish-legacy#1394

GHSA-p9mp-vq4v-v5m5 is a security vulnerability in ezsystems/ezpublish-legacy. A fix is available for ezsystems/ezpublish-legacy — see the affected versions and patch details below.

Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

5 pkgs affected
🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

This security advisory fixes a vulnerability in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy.

Installations that are using the legacy LDAP login handler or the TextFile login handler in combination with the standard legacy login handler, may in rare cases be vulnerable to a failure of the standard login handler to verify passwords correctly, allowing unauthorised access.

If your installation has never used the LDAP or TextFile login handlers, or never used legacy login at all, then it is not affected. Still, we recommend installing the update, to be on the safe side.

To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/13f03a2be6c0ee4d0caaafaef05904ea9b0c4d9d

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistezsystems/ezpublish-legacy≥ 2018.9.0&&< 2018.9.1.12018.9.1.1composer require ezsystems/ezpublish-legacy:^2018.9.1.1
🐘Packagistezsystems/ezpublish-legacy≥ 2018.6.0&&< 2018.6.1.22018.6.1.2composer require ezsystems/ezpublish-legacy:^2018.6.1.2
🐘Packagistezsystems/ezpublish-legacy≥ 2011.0.0&&< 2017.12.4.12017.12.4.1composer require ezsystems/ezpublish-legacy:^2017.12.4.1
🐘Packagistezsystems/ezpublish-legacy≥ 5.4.0&&< 5.4.12.15.4.12.1composer require ezsystems/ezpublish-legacy:^5.4.12.1
🐘Packagistezsystems/ezpublish-legacy≥ 5.3.0&&< 5.3.12.45.3.12.4composer require ezsystems/ezpublish-legacy:^5.3.12.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezpublish-legacy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ezsystems/ezpublish-legacy to 2018.9.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p9mp-vq4v-v5m5 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

This security advisory fixes a vulnerability in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy. Installations that are using the legacy LDAP login handler or the TextFile login handler in combination with the standard legacy login handler, may in rare cases be vulnerable to a failure of the standard login handler to verify passwords correctly, allowing unauthorised access. If your installation has never used the LDAP or TextFile login handlers, or never used legacy login at all, then it is not affected. Still, we recommend installing the u
O3 Security · Impact-Aware SCA

Is GHSA-p9mp-vq4v-v5m5 in your dependencies?

Find it across Packagist, including transitive dependencies.

eZ Publish Legacy Passwordless login for LDAP users