eZ Publish Information disclosure in backend content tree menuGHSA-cc2j-92jq-wgjg
Fix: ezsystems/ezpublish-legacy@a4a0470GHSA-cc2j-92jq-wgjg is a security vulnerability in ezsystems/ezpublish-legacy. A fix is available for ezsystems/ezpublish-legacy — see the affected versions and patch details below.
Real-World Exposure
ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
This security advisory fixes an information disclosure vulnerability in the legacy admin content tree menu. If a view has been disabled in site.ini [SiteAccessRules] Rules, and an attacker accesses the backend with the URL to this module, then the tree menu may be displayed. Since the tree menu may contain hidden items, this may lead to information disclosure. We recommend that you install this Security Update as soon as possible.
To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/a4a0470f8d80f012fe14e4f8ab11c7d14375986c
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 2011.0.0&&< 2017.8.1.1 | 2017.8.1.1composer require ezsystems/ezpublish-legacy:^2017.8.1.1 |
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 5.4.0&&< 5.4.10.1 | 5.4.10.1composer require ezsystems/ezpublish-legacy:^5.4.10.1 |
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 5.3.0&&< 5.3.12.2 | 5.3.12.2composer require ezsystems/ezpublish-legacy:^5.3.12.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezpublish-legacy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ezsystems/ezpublish-legacy to 2017.8.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cc2j-92jq-wgjg is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-cc2j-92jq-wgjg in your dependencies?
Find it across Packagist, including transitive dependencies.