CVE-2020-10806 — ezpublish-kernel
CRITICALCVE-2020-10806 is a critical-severity (CVSS 9.8) Unrestricted File Upload vulnerability in ezsystems/ezpublish-kernel. A fix is available for ezsystems/ezpublish-kernel — see the affected versions and patch details below.
eZ Publish Kernel and Legacy Unrestricted Upload of File with Dangerous Type
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
eZ Publish Kernel before 5.4.14.1, 6.x before 6.13.6.2, and 7.x before 7.5.6.2 and eZ Publish Legacy before 5.4.14.1, 2017 before 2017.12.7.2, and 2019 before 2019.03.4.2 allow remote attackers to execute arbitrary code by uploading PHP code, unless the vhost configuration permits only app.php execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ezsystems/ezpublish-kernel | all versions | 5.4.14.1composer require ezsystems/ezpublish-kernel:^5.4.14.1 |
| 🐘Packagist | ezsystems/ezpublish-legacy | all versions | 5.4.14.1composer require ezsystems/ezpublish-legacy:^5.4.14.1 |
| 🐘Packagist | ezsystems/ezpublish-kernel | ≥ 6.0&&< 6.13.6.2 | 6.13.6.2composer require ezsystems/ezpublish-kernel:^6.13.6.2 |
| 🐘Packagist | ezsystems/ezpublish-kernel | ≥ 7.0&&< 7.5.6.2 | 7.5.6.2composer require ezsystems/ezpublish-kernel:^7.5.6.2 |
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 2017&&< 2017.12.7.2 | 2017.12.7.2composer require ezsystems/ezpublish-legacy:^2017.12.7.2 |
| 🐘Packagist | ezsystems/ezpublish-legacy | ≥ 2019&&< 2019.03.4.2 | 2019.03.4.2composer require ezsystems/ezpublish-legacy:^2019.03.4.2 |
Affected Products
ez publish-kernelezez publish-legacyezDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezpublish-kernel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ezsystems/ezpublish-kernel to 5.4.14.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-10806 is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is CVE-2020-10806 in your dependencies?
Find it across Packagist, including transitive dependencies.