eZ Platform Object Injection in SiteAccessMatchListenerGHSA-64vj-933f-6pm3
GHSA-64vj-933f-6pm3 is a remote code execution vulnerability in ezsystems/ezpublish-kernel. A fix is available for ezsystems/ezpublish-kernel — see the affected versions and patch details below.
Real-World Exposure
ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-kernelReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
This Security Advisory is about an object injection vulnerability in the SiteAccessMatchListener of eZ Platform, which could lead to remote code execution (RCE), a very serious threat. All sites may be affected.
Update: There are bugs introduced by this fix, particularly but not limited to compound siteaccess matchers. These have been fixed in ezsystems/ezplatform-kernel v1.0.3, and in ezsystems/ezpublish-kernel v7.5.8, v6.13.6.4, and v5.4.15.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ezsystems/ezpublish-kernel | ≥ 7.5.0&&< 7.5.8 | 7.5.8composer require ezsystems/ezpublish-kernel:^7.5.8 |
| 🐘Packagist | ezsystems/ezpublish-kernel | ≥ 6.13.0&&< 6.13.6.4 | 6.13.6.4composer require ezsystems/ezpublish-kernel:^6.13.6.4 |
| 🐘Packagist | ezsystems/ezpublish-kernel | ≥ 5.4.0&&< 5.4.15 | 5.4.15composer require ezsystems/ezpublish-kernel:^5.4.15 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezpublish-kernel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ezsystems/ezpublish-kernel to 7.5.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-64vj-933f-6pm3 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-64vj-933f-6pm3 in your dependencies?
Find it across Packagist, including transitive dependencies.