NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

eZ Platform REST API returns list of all SiteAccessesGHSA-9wwx-c723-vm8x

Fix: ezsystems/ezpublish-kernel@1551723

GHSA-9wwx-c723-vm8x is a security vulnerability in ezsystems/ezpublish-kernel. A fix is available for ezsystems/ezpublish-kernel — see the affected versions and patch details below.

Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

6 pkgs affected
🐘ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-kernel🐘ezsystems/ezpublish-kernel

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

This security advisory fixes a vulnerability in eZ Platform, and we recommend that you install it as soon as possible. The issue is that the REST API may be made to disclose the names of all available site accesses. The severity of this depends on your installation, please consider your response accordingly.

To install, use Composer to update "ezsystems/ezpublish-kernel" to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-kernel/commit/1551723ec134878a4cb598bfc5d900ba6164117a

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistezsystems/ezpublish-kernel≥ 7.3.0&&< 7.3.2.17.3.2.1composer require ezsystems/ezpublish-kernel:^7.3.2.1
🐘Packagistezsystems/ezpublish-kernel≥ 7.0.0&&< 7.2.4.17.2.4.1composer require ezsystems/ezpublish-kernel:^7.2.4.1
🐘Packagistezsystems/ezpublish-kernel≥ 6.8.0&&< 6.13.5.16.13.5.1composer require ezsystems/ezpublish-kernel:^6.13.5.1
🐘Packagistezsystems/ezpublish-kernel≥ 6.0.0&&< 6.7.9.16.7.9.1composer require ezsystems/ezpublish-kernel:^6.7.9.1
🐘Packagistezsystems/ezpublish-kernel≥ 5.4.0&&< 5.4.13.15.4.13.1composer require ezsystems/ezpublish-kernel:^5.4.13.1
🐘Packagistezsystems/ezpublish-kernel≥ 5.3.0&&< 5.3.12.15.3.12.1composer require ezsystems/ezpublish-kernel:^5.3.12.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezpublish-kernel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ezsystems/ezpublish-kernel to 7.3.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9wwx-c723-vm8x is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

This security advisory fixes a vulnerability in eZ Platform, and we recommend that you install it as soon as possible. The issue is that the REST API may be made to disclose the names of all available site accesses. The severity of this depends on your installation, please consider your response accordingly. To install, use Composer to update "ezsystems/ezpublish-kernel" to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-kernel/commit/1551723ec134878a4cb598bfc5d900ba6164117a
O3 Security · Impact-Aware SCA

Is GHSA-9wwx-c723-vm8x in your dependencies?

Find it across Packagist, including transitive dependencies.

eZ Platform REST API returns list of all SiteAccesses