NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

RubyGems Improper Input Validation vulnerabilityGHSA-p7f2-rr42-m9xm

HIGHFix: rubygems/rubygems@8a38a4f

GHSA-p7f2-rr42-m9xm is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in rubygems-update. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for rubygems-update — see the affected versions and patch details below.

Also known asCVE-2017-0900
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
6.55%9.60%12.6%15.7%11.2%8.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎rubygems-update

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

RubyGems versions 2.6.12 and earlier are vulnerable to maliciously crafted gem specifications that cause a denial of service attack against RubyGems clients who have issued a query command.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsrubygems-updateall versions2.6.13bundle update rubygems-update --conservative

Affected Products

8 products · 13 configurations
OS
debian linuxdebian
2 versions
8.09.0
OS
enterprise linux desktopredhat
1 version
7.0
OS
enterprise linux serverredhat
1 version
7.0
OS
enterprise linux server ausredhat
2 versions
7.47.6
OS
enterprise linux server eusredhat
3 versions
7.47.57.6
OS
enterprise linux server tusredhat
2 versions
7.47.6
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rubygems-update, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rubygems-update to 2.6.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p7f2-rr42-m9xm is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

This issue affects the versions of ruby as shipped with Red Hat Enterprise Linux 6, and 7 and the versions of rh-ruby22-ruby and rh-ruby23-ruby as shipped with Red Hat Software Collections. Red Hat Product Security has rated this issue as having Low security impact. A future update may address this issue. For…

ProductFixed inAdvisory
Red Hat Enterprise Linux 7ruby-0:2.0.0.648-33.el7_4RHSA-2018:0378
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby24-ruby-0:2.4.2-86.el6RHSA-2017:3485
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby22-ruby-0:2.2.9-19.el6RHSA-2018:0583
Red Hat Software Collections for Red Hat Enterprise Linux 6rh-ruby23-ruby-0:2.3.6-67.el6RHSA-2018:0585

Frequently Asked Questions

RubyGems versions 2.6.12 and earlier are vulnerable to maliciously crafted gem specifications that cause a denial of service attack against RubyGems clients who have issued a `query` command.
O3 Security · Impact-Aware SCA

Is GHSA-p7f2-rr42-m9xm in your dependencies?

Find it across RubyGems, including transitive dependencies.

RubyGems Improper Input Validation vulnerability