NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm💎 RubyGems
Not in CISA KEV
HIGH severity

Prototype Pollution in lodashGHSA-p6mc-m468-83gw

HIGHFix: github/advisory-database#2884

GHSA-p6mc-m468-83gw is a high-severity (CVSS 7.4) CWE-770 vulnerability in lodash. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for lodash — see the affected versions and patch details below.

Also known asCVE-2020-8203
Published
Updated
Affected
8 pkgs
Patched
3 / 8
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-p6mc-m468-83gw.

EPSS Exploitation Probability

via FIRST.org ↗
5.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
1.75%3.17%4.59%6.01%3.3%5.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

8 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

197Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
lodashnpm
204.2Mdownloads / week
lodash-esnpm
70.2Mdownloads / week
lodash.picknpm
2.2Mdownloads / week

Description

Versions of lodash prior to 4.17.19 are vulnerable to Prototype Pollution. The functions pick, set, setWith, update, updateWith, and zipObjectDeep allow a malicious user to modify the prototype of Object if the property identifiers are user-supplied. Being affected by this issue requires manipulating objects based on user-provided property values or arrays.

This vulnerability causes the addition or modification of an existing property that will exist on all objects and may lead to Denial of Service or Code Execution under specific circumstances.

Affected Packages

8 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npmlodash≥ 3.7.0&&< 4.17.194.17.19npm install lodash@4.17.19
📦npmlodash-es≥ 3.7.0&&< 4.17.204.17.20npm install lodash-es@4.17.20
📦npmlodash.pick≥ 4.0.0No fix
📦npmlodash.set≥ 3.7.0No fix
📦npmlodash.setwithall versionsNo fix
📦npmlodash.updateall versionsNo fix

Affected Products

18 products · 42 configurations
Application
lodashlodash
< 4.17.20
range
Application
banking corporate lending process managementoracle
3 versions
14.2.014.3.014.5.0
Application
banking credit facilities process managementoracle
3 versions
14.2.014.3.014.5.0
Application
banking extensibility workbenchoracle
3 versions
14.2.014.3.014.5.0
Application
banking liquidity managementoracle
3 versions
14.2.014.3.014.5.0
Application
banking supply chain financeoracle
3 versions
14.2.014.3.014.5.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lodash, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update lodash to 4.17.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p6mc-m468-83gw is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

In OpenShift ServiceMesh (OSSM), Red Hat OpenShift Jaeger (RHOSJ) and Red Hat OpenShift Container Platform (RHOCP), the affected containers are behind OpenShift OAuth authentication. This restricts access to the vulnerable nodejs-lodash library to authenticated users only, therefore the impact is low. Red Hat…

ProductFixed inAdvisory
Jaeger-1.17distributed-tracing/jaeger-agent-rhel7:1.17.6-1RHSA-2020:3370
Openshift Service Mesh 1.1kiali-0:v1.12.10.redhat2-1.el7RHSA-2020:3369
Red Hat OpenShift Container Platform 4.6openshift4/ose-metering-presto:v4.6.0-202010200139.p0RHSA-2020:4298
Red Hat Quay 3quay/quay-rhel8:v3.6.0-62RHSA-2021:3917
Red Hat Virtualization 4 for Red Hat Enterprise Linux 8cockpit-ovirt-0:0.14.15-1.el8evRHSA-2020:5611
Red Hat Virtualization Engine 4.4ovirt-engine-ui-extensions-0:1.2.3-1.el8evRHSA-2020:3807
Red Hat Virtualization Engine 4.4org.ovirt.engine-root-0:4.4.3.8-1RHSA-2020:5179

Frequently Asked Questions

Versions of lodash prior to 4.17.19 are vulnerable to Prototype Pollution. The functions `pick`, `set`, `setWith`, `update`, `updateWith`, and `zipObjectDeep` allow a malicious user to modify the prototype of Object if the property identifiers are user-supplied. Being affected by this issue requires manipulating objects based on user-provided property values or arrays. This vulnerability causes the addition or modification of an existing property that will exist on all objects and may lead to Denial of Service or Code Execution under specific circumstances.
O3 Security · Impact-Aware SCA

Is GHSA-p6mc-m468-83gw in your dependencies?

Find it across npm, RubyGems, including transitive dependencies.

Prototype Pollution in lodash (High 7.4)