CVE-2026-2950 is a medium-severity (CVSS 6.5) CWE-1321 vulnerability in lodash. A fix is available for lodash — see the affected versions and patch details below.
lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit`
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-2950.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
lodashnpmlodash-esnpmlodash-amdnpmDescription
Impact
The _.unset, _.omit, and _.pullAt functions are vulnerable to prototype pollution. The fix for CVE-2025-13465 only guards against string key members, so an attacker can bypass the check by passing array-wrapped path segments. This allows deletion of properties from built-in prototypes such as Object.prototype, Number.prototype, and String.prototype.
The issue permits deletion of prototype properties but does not allow overwriting their original behavior.
Patches
The issue is patched from 4.18.0 to 4.18.1 depending on the package: lodash, lodash-es, and lodash-amd in 4.18.1, and the standalone lodash.unset and lodash.omit packages in 4.18.0.
Workarounds
None. Upgrade to the patched version.
References
- CVE-2025-13465 / GHSA-xxjr-mmjv-4gpg (original fix that this bypasses)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | lodash | ≥ 4.17.23&&< 4.18.1 | 4.18.1npm install lodash@4.18.1 |
| 📦npm | lodash-es | ≥ 4.17.23&&< 4.18.1 | 4.18.1npm install lodash-es@4.18.1 |
| 📦npm | lodash-amd | ≥ 4.17.23&&< 4.18.1 | 4.18.1npm install lodash-amd@4.18.1 |
| 📦npm | lodash.unset | all versions | 4.18.0npm install lodash.unset@4.18.0 |
| 📦npm | lodash.omit | all versions | 4.18.0npm install lodash.omit@4.18.0 |
Affected Products
lodashlodashlodash-amdlodashlodash-eslodashlodash.unsetlodashDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lodash, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update lodash to 4.18.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-2950 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-2950 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | cockpit-0:356.1-1.el10_2 | RHBA-2026:21388 |
| Red Hat Enterprise Linux 9 | cockpit-0:356.1-1.el9_8 | RHBA-2026:21387 |
| Red Hat Developer Hub 1.10 | rhdh/rhdh-hub-rhel9:1780930740 | RHSA-2026:24841 |
| Red Hat Hardened Images | nodejs25-main-11.12.1-1.25.9.0.1.1.hum1 | RHSA-2026:7378 |
| Red Hat Hardened Images | yarnpkg-main-1.22.22-18.1.hum1 | RHSA-2026:7655 |
| Red Hat Hardened Images | nodejs20-main-10.8.2-1.20.20.2.1.hum1 | RHSA-2026:9455 |
Frequently Asked Questions
Is CVE-2026-2950 in your dependencies?
Find it across npm, including transitive dependencies.