NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2019-10744 — lodash

CRITICALFix: lodash/lodash#4336

CVE-2019-10744 is a critical-severity (CVSS 9.1) CWE-1321 vulnerability in lodash. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for lodash — see the affected versions and patch details below.

Prototype Pollution in lodash

Also known asGHSA-jf85-cpcp-j695SNYK-JS-LODASH-450202
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%6.10%12.2%18.3%3.3%5.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

197Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
lodashnpm
204.3Mdownloads / week
lodash-esnpm
69.9Mdownloads / week
lodash-amdnpm
9Kdownloads / week

Description

Versions of lodash before 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep allows a malicious user to modify the prototype of Object via {constructor: {prototype: {...}}} causing the addition or modification of an existing property that will exist on all objects.

Recommendation

Update to version 4.17.12 or later.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
📦npmlodashall versions4.17.12npm install lodash@4.17.12
📦npmlodash-esall versions4.17.14npm install lodash-es@4.17.14
📦npmlodash-amdall versions4.17.13npm install lodash-amd@4.17.13
📦npmlodash.defaultsdeepall versions4.6.1npm install lodash.defaultsdeep@4.6.1
💎RubyGemslodash-railsall versions4.17.12bundle update lodash-rails --conservative

Affected Products

21 products · 81 configurations
Application
big-ip access policy managerf5
≥ 15.1.0 && < 15.1.0.2
range
Application
big-ip advanced firewall managerf5
≥ 15.1.0 && < 15.1.0.2
range
Application
big-ip analyticsf5
≥ 15.1.0 && ≤ 14.1.2
range
Application
big-ip application acceleration managerf5
≥ 15.1.0 && < 15.1.0.2
range
Application
big-ip application security managerf5
≥ 15.1.0 && < 15.1.0.2
range
Application
big-ip application visibility and reportingf5
≥ 15.1.0 && ≤ 13.1.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lodash, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update lodash to 4.17.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10744 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

The lodash dependency is included in OpenShift Container Platform (OCP) by Kibana in the aggregated logging stack. Elastic have issued a security advisory (ESA-2019-10) for Kibana for this vulnerability, and in that advisory stated that no exploit vectors had been identified in Kibana. Therefore we rate this issue as…

ProductFixed inAdvisory
Jaeger-1.17distributed-tracing/jaeger-all-in-one-rhel7:1.17.2-3RHSA-2020:2819
Openshift Service Mesh 1.0jaeger-0:v1.13.1.redhat7-1.el7RHSA-2020:2362
Red Hat AMQ 7.10.0nodejs-lodashRHSA-2022:5101
Red Hat Fuse 7.10nodejs-lodashRHSA-2021:5134
Red Hat Virtualization Engine 4.3ovirt-web-ui-0:1.6.0-1.el7evRHSA-2019:3024

Frequently Asked Questions

Versions of `lodash` before 4.17.12 are vulnerable to Prototype Pollution. The function `defaultsDeep` allows a malicious user to modify the prototype of `Object` via `{constructor: {prototype: {...}}}` causing the addition or modification of an existing property that will exist on all objects. ## Recommendation Update to version 4.17.12 or later.
O3 Security · Impact-Aware SCA

Is CVE-2019-10744 in your dependencies?

Find it across npm, RubyGems, including transitive dependencies.

CVE-2019-10744: lodash — Fixed in 4.17.12